Back to overview
Service Disruption - January 20, 2026
Jan 20, 2026 at 10:00am UTC
Affected services
App
API Services
Resolved
Jan 20, 2026 at 10:00am UTC
Summary
| Item | Details |
|---|---|
| Date | January 20, 2026 |
| Duration | Approximately 2 hours 10 minutes |
| Impact | API services temporarily unavailable |
Timeline (UTC+8)
| Time | Event |
|---|---|
| 15:50 | Service disruption detected |
| 16:20 | Root cause identified, remediation started |
| 17:40 | Services restored |
| 18:00 | Full recovery confirmed |
What Happened
A database performance issue caused resource exhaustion, which led to API services becoming temporarily unavailable. During this period, users may have experienced timeouts or failed requests when accessing our services.
What We Did
- Identified and terminated the problematic database queries
- Restored normal database operations
- Optimized database configuration to prevent recurrence
- Enhanced monitoring and alerting for early detection
Prevention
We have implemented additional safeguards to prevent similar incidents in the future, including improved query timeout settings and proactive database health monitoring.
Apology
We sincerely apologize for any inconvenience this disruption may have caused. We are committed to maintaining the reliability of our services and will continue to improve our infrastructure.
If you have any questions, please contact us at support@nonce.app.
Affected services